Home Button  Buy Button 

Topic:   MySQL 8.0.17

By: IanPosted on: Sep 23 2019 at 08:28:06 AM
I want to transfer to MySQL, but cannot get SQLtools to connect to my recent install of MySQL 8.0.17. I have tried using server names '' and 'localhost'. I get the error: Could not connect... Is the server running, and does the user have permissions.

Using the MySQL workbench I can connect to the database with the correct user name and password, and have backup/restore privileges.

By: SupportPosted on: Sep 23 2019 at 09:21:16 AM
During the install of MySQL 8 you get to a page that asks about authentication mode. Currently you would need to select the standard connection/authentication (unencrypted mode compatible with MySQL 5)

But the [User] tab in DBTools is still broken so you'd need to create additional 'Standard' users using other tools such as PHPMyAdmin or MySQLWorkbench

We are working on the update for MySQL v8. Can't say exactly how long that will take but it should be very soon.

By: GuestPosted on: Sep 23 2019 at 10:40:57 AM
I had the same problem

Open the MySQL Installer and select the 'Reconfigure' option.

Go back through the options leaving them all as they are till you hit the 'Authentication' page. Toggle the option for v5 compatibility.

Gontinue to the end of the setup.

Then go back to MiniMRP's DBTools and you should find it connects now.

By: IanPosted on: Sep 23 2019 at 03:49:04 PM
Thanks.. That worked, but I can only log on with the root account. I have another user account that appears to have the same privileges but it isn't recognised. I can work with root account for the time being.

By: SupportPosted on: Sep 24 2019 at 02:57:34 AM
We have an update ready for MiniMRP that fully supports the new MySQL v8 security.

We just finishing testing on different old/new Server versions.

So, if you can struggle on using your root for a couple days more I'll come back to this page and tell you when the update is ready for download.

By: SupportPosted on: Sep 25 2019 at 06:51:57 AM
The latest version available on the downloads page is 5.0.51 Try that and let us know if it fixes this problem.

Reply - add a comment to this topic.

You may enter letters, numbers and standard punctuation only. HTML and other scripts/tags will be rejected.

Topic:- MySQL 8.0.17

Enter the numbers.

Your name here is optional